Go Back   Land Rover Forum > Land Rover Specific Models > Discovery I

Discovery I Discuss here about the first version of Land Rover Discovery (Disco I) in this section.


Reply
 
Thread Tools Display Modes
Old 02-20-2015, 08:10 PM   #1
Roundgate
Junior Member
 
Join Date: Feb 2015
Location: Utah
Posts: 1
Question 1998 Discovery Code: p1314 Running Rough, already replaced several things

Hey guys,
1998 Disco LSE 4.0L
I've had a number of issues, and have already replaced a bunch of stuff, but now I'm pretty much at a loss.
Currently it's throwing a p1314 code (Misfire likely to damage catalyst). It's running rough, but not always. It usually will run fine when started, but after driving for a little bit it will run rough, lose power, etc.

Here's the history of the issue:
2011- Bought it, it had a check engine light on, but nothing seemed to be affected.
2012- Checked the code- It was a P1193 or P1191, (don't remember which) Oxygen Sensor Heater Circuit Open downstream (At the time, had no idea what that was referring to so I left it. (Smart right?))

Last year 2014, started getting worse MPG,
June, I'm driving in the mountains, and I feel a slight stutter and loss of power, but didn't feel it again till;
July, Car wash: washing the engine compartment because it was covered in mud, then it wont start. A few hours later, get it to start, but running extremely rough and backfiring. After a couple of minutes, the Drivers side cat was red hot (fuel wasn't igniting till it was in the cat.) Not drive-able. Cylinder 1 wasn't firing.
Since then, I've replaced:
Coils, Plugs, Wires, Drivers side Cat, o2 sensor, (and the alternator; it wasn't putting out enough voltage; probably unrelated.)
Before I replaced the cat and the o2 sensor, I checked to see if coil 1 was giving spark to cylinder 1; it wasn't.
Going to test the new coil I'll let you know what I find out.
After I replaced each one of those things, it would run ok for a day or two, then go back to running poorly.
After I replaced the Cat and O2 sensor it ran great, with plenty of power, but a few days later, it started running poorly again, which is where I'm at now.

Could it be a control module issue? another sensor issue?
Roundgate is offline   Reply With Quote
Old 02-21-2015, 10:52 AM   #2
Joey
Administrator
 
Joey's Avatar
 
Join Date: Mar 2011
Location: Liberty Twp, OH
Posts: 209
Garage
Default

Welcome to the forum. My recommendation is to clean your Mass Air Flow sensor. It may not sound related, but on a Rover it probably is. Also check to make sure you have a good clean air filter.
__________________
This forum is not used much... please go to:

http://www.landroverworld.org/forums/index.php


Joey
Cincinnati OH
http://www.customroveraccessories.com Home of the New D2 horn buttons!
97 Disco (rusted frame being parted out with Nathan below.
02 Disco Sold due to only driving it 2k miles in 2 years
2013 Jaguar XF (my daily driver)
1946 Dodge Custom 4D (my project)
http://www.usarovers.com/ (call for Rover parts ask for Nathan 502-222-5859)

Rover Radio issues or IPOD Adapters http://home.valornet.com/splacket/index.htm

EAS fault http://www.rswsolutions.com

When working with GEMS vehicles. Never try to locate a misfire by pulling plug leads off - pull the injector connector instead. Otherwise you can blow up the ECU.

Secondly never swap ECUs between vehicles to test them, because both vehicles and ECUs may stop working, and you'll have to have them all reset by a franchised LR dealer (ouch!).

To download the RAVE manual, follow this link http://www.landroverresource.com/
Joey is offline   Reply With Quote
Reply

Bookmarks

Tags
discovery, loss of power, p1314, running rough

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:54 AM.


Sponsor Ads

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Garage vBulletin Plugins by Drive Thru Online, Inc.