Go Back   Land Rover Forum > Land Rover Specific Models > Discovery I

Discovery I Discuss here about the first version of Land Rover Discovery (Disco I) in this section.


Reply
 
Thread Tools Display Modes
Old 04-20-2020, 02:58 PM   #11
mileys1990
Junior Member
 
Join Date: Jan 2020
Age: 31
Posts: 1
Default

I start the car it will run like 3 miles and then it slows down, but the rpm is high. tubemate mobdro subway surfer mod

Last edited by mileys1990; 04-21-2020 at 07:33 AM.
mileys1990 is offline   Reply With Quote
Old 04-20-2020, 03:15 PM   #12
Joey
Administrator
 
Joey's Avatar
 
Join Date: Mar 2011
Location: Liberty Twp, OH
Posts: 224
Garage
Default

If the RPM's stay up, but the vehicle slows down this is a transmission issue. Check the fluid level.
__________________
This forum is not used much... please go to:

http://www.landroverworld.org


Joey
Cincinnati OH
http://www.customroveraccessories.com Home of the New D2 horn buttons!

http://www.usarovers.com/ (call for Rover parts ask for Nathan 502-222-5859)

Rover Radio issues or IPOD Adapters http://home.valornet.com/splacket/index.htm

EAS fault http://www.rswsolutions.com

When working with GEMS vehicles. Never try to locate a misfire by pulling plug leads off - pull the injector connector instead. Otherwise you can blow up the ECU.

Secondly never swap ECUs between vehicles to test them, because both vehicles and ECUs may stop working, and you'll have to have them all reset by a franchised LR dealer (ouch!).
Joey is offline   Reply With Quote
Reply

Bookmarks

Tags
problems

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:29 AM.


Sponsor Ads

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Garage vBulletin Plugins by Drive Thru Online, Inc.